The Sporum - The Official Spore Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to forum index 
[Login] Login 
Forum Index » Spore Mac Help [XML]
 Topic   Answers   Author   Views   Last message 
Can't get Creepy and Cute since recent update [Updated with workaround - Oct 17]
[ Go to page: 1, 2 ]
25 CarnijawEmperor 2875 11/02/2017 17:40:25
SporeMasterDOGC_Kyle [Latest Reply]
FAQ / Master Help Thread for Macs
[ Go to page: 1, 2, 3  ...  6, 7, 8 ]
107 ZeekNyne9 50923 04/29/2014 18:19:16
andybradshaw68 [Latest Reply]
Crash on Mac 10.6.3
[ Go to page: 1, 2, 3, 4 ]
46 SporeMasterSlime 35090 12/09/2013 21:11:31
Johnnamelon [Latest Reply]
Patch Mac Help
[ Go to page: 1, 2, 3  ...  8, 9, 10 ]
135 SporeMasterKaliena 50854 07/22/2012 06:56:22
Rellick13 [Latest Reply]
Dr. Pepper Robot parts for Mac
[ Go to page: 1, 2, 3  ...  6, 7, 8 ]
115 SporeMasterSlime 39590 06/15/2012 06:42:36
Brhinock [Latest Reply]
we are unable to connect to ea servers to activate spore on this computer using your account. Please 1 DragonMaster6981 63 01/15/2018 19:56:06
SporeMasterDOGC_Kyle [Latest Reply]
Cannot play spore due to lags and glitch lines. 6 ghostgirl708 557 01/08/2018 14:40:36
DragonMaster6981 [Latest Reply]
Game won't start.... 12 MeIzBlue 24354 01/08/2018 02:16:42
DarkMagickan [Latest Reply]
does anyone here play spore
[ Go to page: 1, 2 ]
17 Garfielf 365 01/01/2018 19:06:43
Gabrieletheman00 [Latest Reply]
Bot Parts must be downloaded in Macintosh (who haves Mac) LIKE an Mod :( 3 Gabrieletheman00 239 01/01/2018 19:04:49
Gabrieletheman00 [Latest Reply]
Mac Patch 5 / 1.05.001
[ Go to page: 1, 2, 3, 4, 5, 6 ]
85 SporeMasterKaliena 86322 12/25/2017 18:38:45
fungus3 [Latest Reply]
10.13.2 (High Sierra) Spore fails to launch 0 MPLewis 203 12/17/2017 23:44:02
MPLewis [Latest Reply]
Help! Mouse Buttons inoperative in Spore under High Sierra 6 chabbu2 987 12/01/2017 20:15:53
jedijov [Latest Reply]
Bot Parts must be downloaded in Macintosh (who have some it)like an Mod (Who only have Macintosh) :( 3 Gabrieletheman00 420 11/24/2017 20:04:48
ChocIce75 [Latest Reply]
Still crashing at startup after patch (Mac)
[ Go to page: 1, 2, 3 ]
39 totheextreme 11066 10/17/2017 01:30:37
WyvernPerson7 [Latest Reply]
 
Forum Index » Spore Mac Help
Go to:   
[New Folder] New messages    [Folder] No new messages    [Announce Folder] Announce
[New Hot] New messages [ hot ]    [Hot] No new messages [ hot ]    [Sticky] Sticky
[Lock New] New messages [ blocked ]    [Lock] No new messages [ blocked ]    [Lock] Moved to another forum
Forum Leaders: Administration SporeMasters
 
Powered by JForum 2.1.8 © ( EA Dev Build 2016-08-15 15:16:49 ) JForum Team